This project is read-only.

Using query in Aggregate Datasource

Jan 30, 2011 at 7:23 PM

I am successfully using an aggregate datasource to combine results of a CrossSiteDataSource and an SQLDataSource.


I want to filter the results by the presence of a value of a choice column in the SharePoint list.


when I add the following Query to the CrossSiteDataSource definition:

         <FieldRef Name='DonorMeeting' />
         <Value Type='Choice'>invite</Value>

There are no results returned, yet there are several records with this value in that column. (the column is a dropdown choice column that does not allow fill in and is not required.)

I have tried using double (") instead of single (') quotes, I have tried filtering against other columns and column types.  Nothing works. 

Any help is much appreciated.


Jan 30, 2011 at 7:39 PM

I was using the U2U CAML query Builder.


It turns out that the formatted output of the tool is bad for the Datasource.  I removed line breaks and tabs and it works just fine.

Jan 31, 2011 at 4:04 PM

@bjones. thanks for porting the issue.